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Sensor board lineup

1 Accelerometer KX022-1020
2 Pressure sensor BM1383GLV
3 Magnetic sensor BM1422GMV
4 ALS/PS sensor RPR-0521RS
5 Color sensor BH1745NUC
6 Hall sensor BD7411G

7 Temperature sensor BD1020HFV
8 UV sensor ML8511A
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ROHM Sensor Shield

For I2C I/F device

« Shield for Arduino Uno

« Size: 88mm x 63mm

« I/F: I12C/Analog/Digital

« Operation Voltage:5V, 3V and1.8V

Embedded Level Shifter
GPIO : FAIRCHILD FXMA108
I2C : NXP PCA9306

« I2C pull-up register
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Feature of each sensor board

Through Hall: I/F pin, VDD and GND Pin (Fig.1)
Board Size: 20mm x 20mm
Board Color: Black

The board has pattern to change Slave address.(Fig.2)
* KX022-1020, BM1422GMV, BH1745NUC

M3 Size Hall to attached some device.

20mm KX022-1020
A BM1422GMV

20mm<

Default

Change Slave address by Cutting
GND-ADDR line and Connect
VDD-ADDR line.

BH1/745NUC

Default

Change Slave address by Cutting
VDD-ADDR line and Connect

GND-ADDR line.

Fig.1 Fig.2
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Manual of Arduino Sensor Shield and Sensor Board

1. Connect between Arduino and Sensor Shield

& (AT 3
0 4.4

usB
Connector

2. Select Sensor Board which connect to Sensor Shield
ex) Connect BM1383GLV to 12C_1

3. Voltage Setting of Sensor Shield
ex)1.8V

4. Connect PC to Arduino by USB Cable
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Manual of Arduino Sensor Shield and Sensor Board

ROHIM

SEMICONDUCTOR

5. Copy Arduino program to libraries of Arduino
* Recommended system requirements : Arduino IDE version 1.6.7 or above
* Please download Arduino IDE from http://www.arduino.cc

6. Execute Arduino IDE(v1.6.7)

'-e@ sketch_jan29a | Arduing 1.6. LEE
Eile Edit Sketch Tools Help

sketch_jan289a

Jaid setupl) | -
/4 put wour setur code here, to run once:

1

vaid loop() {
A/ put wour main code here, to run repeatedly:

1

7. Select Program

*  File->Examples->BM1383GLV->
example->BM1383GLV
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Frern r ==
Ctrl+N
Ctrl+0

New
Open...
Open Recent 3
Sketchbook 2

' s
oo +W 04.Communication

Save Ctrl+S 05.Control
Save As...  Cirl+Shift+5 08.5ensors
07.Display
Page Setup  Ctrl+Shift+P 08.5trings
Print Ctrl+P 09.USE

10.StarterkKit

10.StarterKit_BasicKit
11.ArduinoISP
ArduincISP

Preferences  Ctrl+72+

*r vy v v v v v v ¥

Quit Ctrl+Q

Examples from Libraries
Bridge

EEPROM
Ethernet
Firmata
GSM
LiquidCrystal
sD
Servo
SoftwareSerial
SPI
Stepper
Temboo
Wire
RETIRED

Examples from Custom Libraries
BD1020HFV

BD7411G 2
BH 45
BM1383GLV example ) BM1383GLV

BM1422GMV
KX022
ML8511
RPR-0521RS

v

)
3
»
»
»




Manual of Arduino Sensor Shield and Sensor Board

8. Change Setting of Board and Port

144 H H 174 il Edi k h | |
(1)Tools->Board ="Arduino/Genuino Uno”, Je e s nep

(2)Port="COMxx(Arduino/Genuino Uno)” Auto Format

Archive Sketch

Fix Enceding & Reload

Serial Monitor Ctrl+Shift+M
Serial Plotter Clrl+Shift+L

Em1383GLY

COM Port Number depends on PC.

Board: "Arduino/Genuino Uno"
Port: "COM16 (Arduino/Genuino Uno)"

Programmer: "AVRISP mKkII"
Burn Bootloader

ArduinofZenuino Uno on COMA1G
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Manual of Arduino Sensor Shield and Sensor Board

9. Write Program (Push Upload Button) 10.Check status whether Write
Program is OK or Not.

OK log is "Done uploading”.

Eile Edit Sketch Tools Help

B ovisasey | adore 1o ===
File Edit Sketch Tools Help

Bhi1383GLY

ArduinofFenuing Uno an COMAG

ArduinefGenuine Uno on COMAG
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Manual of Arduino Sensor Shield and Sensor Board ROHM

(25 BM1383GLV | Arduino 1.6. [ ———)
File Edit Sketch Help

Auto Format
Archive Sketch

Fix Encoding & Reload
I Serial Monitor l Ctrl+Shift+M || =

Serial Plotter Crl+Shift+L

Bhi1383GLY

Board: "Arduino/Genuino Uno”
Port: "COM16 (Arduino/Genuino Uno)"

Programmer: "AVRISP mkII"
Burn Bootloader

11.Select Tools->Serial Monitor
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Manual of Arduino Sensor Shield and Sensor Board ROHM

(=

BM1383GL ID Register Yalue = 0x31

BM1383GLY (PRESZ) = 1013.13 [hPa]
Bh1383GLY

R BM1383GLY (PRESS) = 1013.18 [hPal
BM1333GLY. ino

BM1383GLY (PRESS) = 1013.17 [hPal

Copyright {c) 2018 ROHM Co.,Ltd.

BM1383GLY (PRESZ) = 1018.20 [hPal
Permizzion iz hereby granted, free of charze, to any person obtaining a copy
of thiz software and associated documentation files (the "Software™), to dec
in the Software without restriction, including without limitation the rizhts
to use, copy, modifw, merze, publish, distribute, sublicenze, andfor zell
copies of the Software, and to permit personz to whom the Software is
furnizhed to do =0, subject to the following conditions:

BM1283GLY (PRESS) = 1013.18 [hPal
BM1383GLY (PRESS) = 1013.18 [hPal
BM1383GLY (PRESS) = 1013.19 [hPal

The above copyright notice and thizs permission notice shall be included in BMI383GLY (PRESS) = 1013, (hPa]

all copies or substantial portions of the Software.

BM1283GLY (PRESS) = 1012.18 [hPal
THE SOFTWARE 1S PROVIDED “43 13°, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
TMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHSNTABILITY, BMIS83GLY (PRESS) = 1013.13 [hPs]

FITHESE FOR & PARTICULAR PURPOSE AWD WOWINFRINGEMEWT. IW WO EYENT SHALL THE

s ——— EM1383GLY (PRESS) = 1013.21 [hPal

BM1383GLY (PRESSY = 1013.16 [hPal

BM1383GLY (PRESS) = 1013.18 [hPal

BM1283GLY (PRESS) = 1013.18 [hPal

r%'l

Mo line ending || 9600 baud

12. Check log of Serial Monitor
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In the case of I2C I/F (KX022) 12C ROHM

[Program] Sketch Tools Help

File->Exam pIeS-> KKD22_WHO_AMT Rezister Walue = 0x14
kX022 () = 0.18 [g]

KX022->example-> Moee: oo @

K022, ino
KX022 a2 0 - 018 03

Copyright (c) 2016 ROHM Co.,Ltd.
Kx02e (Z) .99 [£]

Permizsion is hereby granted, free of charge, to any person obtaining a copsl
of this software and associated documentation files (the “Software”), to dec K¥DZ2 (X) 17 [e]
in the Software without restriction, including without limitation the rights Kxpzz (¥) 08 [g]
to use, copy, modify, merge, publish, distribute. sublicense, andfor sell Kx02z (2 99 [e]
copies of the Software. and to permit persons to whom the Software is
furnizhed to do so, subject to the faollowing conditions: KxDzz (x) 18 [g]
Kx02e () 06 [2]
The abowve copyright notice and this permizsion notice shall be included in K22 (2) -89 [e]
all copies or substantial portions of the Software.
kX022 () RENE
THE SOFTWARE 1S PROVIDED &5 IS, WITHOUT WARRANTY OF ANV KIND, EXPRESS OR K02z (v} = 0.06 [&]
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRAMTIES OF WERCHANTABILITY, KNO22 (Z) = 0.89 [¢]

FITHESS FOR & PARTICULAR PURPOSE AND NOWINFRIMWGEMENT. IM WO EYEWT SHALL THE
el e o oo oo Kxnee (K) RE [g]

Kx022 (¥ = 0.06 [g]
Ex022 (Z) = 0.89 [g]

Hoze (%) = 0,18 [g]
Kx022 (¥ = 0.06 [g]
KH022 (2 = 0.99

[] futoscrall Mo line ending | 9600 baud

[Result of Sample Program]
Display output data of X, Y, and Z axis at 500ms interval.
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In the case of

GPIO I/F (BD7411)

ROHIM

SEMICONDUCTOR

[Program]
File->Examples->

@ = | O x

File Edit Sketch Tools Help

BD7411G->example->f *"

BD7411

£

BO7411. ino
Copyrizht {c) 2016 ROMM Co.,Ltd.

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software”), to des—
in the Software without restriction, including without limitation the right:
to uge, copy, modify, merze, publish, distribute, sublicense, andfor =el
copies of the Software, and to permit persons to whom the Software is
furnished to do so. subject to the following conditions:

The above copyright notice and this permizsion notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "43 I3", WITHOUT WARRAMTY OF ANY KIND, EXPRESS DR

X Caution

When Sample program
of BD7411 is installed,
Take off BD7411 Sensor
Board.

IMPLIED, IWCLUDIWG BUT WOT LIMITED TO THE WARRAWTIES OF MERCHANTABILITY.
FITHESS FOR & PARTICULAR PURPOSE AND NOMIWFRINGEMENT. IN WO EVENT SHALL THE .

© 2016 ROHM Co.,Ltd.

[Result of Sample Program]

£5 COM16 (Arduino/G =)

BD?A11G Sample

BD7411G Mazret field Detct!

BD7411G Magnet field Detct!

BD?411G Magnet field Detct!

BD7411G Mazret field Detct!

BOP411G Magnet field Detct!
BOP411G Magnet field Detct!
BD?411G Maznet field Detct!
BD?411G Maznet field Detct!

BD7411G Maznet field Detct!

Mo ling ending | | 9500 baud

Display message at 500ms interval when BD7411 output is low.
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In the case Analog I/F (BD1020) ROHM

[Program] T —

File->Examples-> BDI020Y Saaelc

BDT0ZOHFY Temp=25. [dezrees Celsius], ADC=265

BOM020 BD1020HFY Tenp=28.95 [degrees Gelsius], ADC=26%

B D 1020 H FV->exam ple-> ; BD1020HFY Tenp=28.85 [desrees Celsius], ADC=268
100 i —l¥{eorozonFy Tenp=zs.95  [dezrees Celsius], ADG-269

BD1020HFY Temp=28. [degrees Celsius], ADC=262

B Dlozo Copwrizht (o) 2016 ROMM Co.,Ltd. BDM0ZOHFY Temp=28. [degrees Celsius], ADC=268
BOTOZOHFY Temp=25. [dezrees Celsius], ADC=2G5
Tenp=24. [degrees Celsius], ADC=262

Tenp=28. [dezrees Celsius], ADC=283
BDT0ZOHFY Temp=28. [degrees Celsiuz], ADC2E3
BO1020HFY Temp=29. [degrees Celsius], ADC=268
BDT0ZOHFY Temp=25. [dezrees Celsius], ADC=265
BDTO2OHFY Temp=28. [dezrees Celziuz], ADC=268
BD1020HFY Temp=28. [degrees Celsius], ADC=268
BOTOZOHFY Temp=25. [dezrees Celsius], ADC=2G5
BD1020HFY Temp=28. [degrees Celsius], ADC=268
BD1020HFY Temp=28. [degrees Celsius], ADC=268

THE SOFTWARE IS PROVIDED “AS 13", WITHOUT WARRANTY OF &NY KIND, ENPRESS OR BDID20HFY Tenp28.85  [degrees Celsius], ADC=263
IWPLIED, INCLUDING BUT MOT LIMITED TO THE WARRANTIES OF WERCHANTABILITY, BD1020HFY Tenp=28.95  [dezrees Cslsius], ADC=268

FITHESS FOR & PARTICULAR FURFOSE AND NONINFRINGEMENT. 1M WO EVENT sHall THE _ [flllB01020HFY Tenp=28.85  [desrees Celsius], ADC=268
memo e oo S ey BDT0ZOHFY Temp=28. [degrees Celsiuz], ADC2E3

Tenp=24. [degrees Celsius], ADC=262

Tenp=28. [dezrees Celsius], ADC=2G%
BDT0ZOHFY Temp=28. [degrees Celsiuz], ADC2E3
BO1020HFY Temp=29. [degrees Celsius], ADC=268
BDT0ZOHFY Temp=25. [dezrees Celsius], ADC=265
BDTO2OHFY Temp=28. [dezrees Celziuz], ADC=268
BD1020HFY Temp=28. [degrees Celsius], ADC=269

Permiszion is hereby granted, free of charge, to any person obtaining a copy
of thiz software and associated documentation files (the "Software”), to des™
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do =0, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

[7] Autoscrall Mo line ending | 9600 baud

[Result of Sample Program]
Display output data of Temperature sensor at 500ms interval.
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Connection Point of Sample Program

TypeName |

1 Accelerometer KX022-1020 12C 1,12C 2,12C _3,12C 4,12C_5
2 Pressure sensor BM1383GLV 12C 1,12C 2,12C _3,12C 4,12C_5
3 Magnetic sensor BM1422GMV 12C 1,12C 2,12C _3,12C 4,12C_5
4  ALS/PS sensor RPR-0521RS 12C_1,12C_2,12C_3,I12C _4,I12C 5
) Color sensor BH1745NUC 12C 1,12C 2,12C _3,12C 4,12C_5
6 Hall sensor BD7411G GPIO

7 Temperature sensor BD1020HFV ANALOG 2

8 UV sensor ML8511A ANALOG 1
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Selectable Power Supply ROHM

Recomr\cglr;geg [(\)/;])eratmg Selectable Power [V]
Sensor Type Name J

Min. Typ. Max 1.8 3 5
Vdd 1.71 2.5 3.6
1 Accelerometer KX022-1020 O O
Vio 1.7 - Vdd
2 Pressure sensor BM1383GLV VDD 1.7 - 3.6 O O
AVDD 1.7 - 2.0
3 Magnetic sensor BM1422GMV
DVDD 1.7 - 2.0
VCC 2.5 3.0 3.6
4 ALS/PS sensor RPR-0521RS O
VLEDA 2.8 3.0 5.5
5 Color sensor BH1745NUC Vce 2.3 2.5 3.6 O
6 Hall sensor BD7411G VDD 45 5.0 55
7 HENIEE S BD1020HFV VDD 2.4 3.0 5.5 ®
sensor
8 UV sensor ML8511A VDD 2.7 3.3 3.6 O
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[2C Device Address List

Type Name Device Address(7bit)

1  Accelerometer KX022-1020 Ox1E/Ox1F
2 Pressure sensor BM1383GLV 0x5D
3 Magnetic sensor BM1422GMV OxOE/OxOF
4  ALS/PS sensor RPR-0521RS 0x38
5  Color sensor BH1745NUC 0x38/0x39

Blue character is default slave
address
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SEMICONDUCTOR
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Looking for pricing, stock, or lifecycle information?

Click below to explore more details on WIN SOURCE:

© View SENSORSHIELD-EVK-001 on WIN SOURCE

@ thm Semiconducto:l Information

Optimize Your Supply Chain with WIN SOURCE Solutions

Global Sourcing Solution
Obsolete Management
Cost Control Management
Shortage Management
Alternative Solution

Excess Inventory Management


https://www.win-source.net/products/detail/rohm-semiconductor/sensorshield-evk-001.html
https://www.win-source.net/manufacturer/rohm-semiconductor

