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Copyrights

© Cypress Semiconductor Corporation, 2011. The information contained herein is subject to change without notice. Cypress
Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress
product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor
intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express
written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-
support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The
inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use
and in doing so indemnifies Cypress against all charges.

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by
and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty
provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create
derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom soft-
ware and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as speci-
fied in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source
Code except as specified above is prohibited without the express written permission of Cypress.

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATE-
RIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein.
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support sys-
tems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all
charges.

Use may be limited by and subject to the applicable Cypress software license agreement.

PSoC®is a registered trademark and PSoC Designer™ is a trademark of Cypress Semiconductor Corp. All other trademarks
or registered trademarks referenced herein are property of the respective corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guaran-
tee the security of their code. Code protection does not mean that we are guaranteeing the product as ‘unbreakable’.

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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Thank you for your interest in the CY3217-MiniProgl Kit. The MiniProgl programmer is designed to
help hardware, firmware, and software developers in building their own systems around the Cypress
8-bit PSoC® 1 devices. You can use the CY3217-MiniProgl kit with PSoC Designer™ and PSoC
Programmer. This kit can be used as an in-system serial programmer (ISSP) to program PSoC 1

devices. The MiniProgl can also supply power to a target board at 5 V.

Cypress does not recommend the MiniProgl in this kit for production programming. For production
programming, see a list of qualified vendors on the General PSoC Programming page of the

Cypress website.

1.1 Kit Contents

The CY3217-MiniProgl Kit contains:
m MiniProgl programmer
m USB A to Mini B cable
m CY3217-MiniProgl kit CD
o PSoC Designer installation file
PSoC Programmer installation file

Kit guide
Quick start guide
Release notes

a o a o o

Bridge Control Panel installation file (packaged along with PSoC Programmer)

Inspect the contents of the kit; if any parts are missing, contact your nearest Cypress sales office for

further assistance.

1.2 Additional Learning Resources

Visit http://lwww.cypress.com for additional learning resources in the form of data sheets, technical

reference manual, and application notes.
m For more information on PSoC Designer functionality, releases, and FAQ:
http://www.cypress.com/go/psocdesigner

m For more information on PSoC Programmer, supported hardware, and COM layer:

http://www.cypress.com/go/psocprogrammer
m For alist of PSoC Designer-related trainings:
http://www.cypress.com/?rID=40543

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A
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Document History

. PDFCreation | Origin of A
Revision Date Change Description of Change
b 07/21/2011 RKPM Initial version of kit guide
A 09/14/2011 RKPM #}gd:;iﬂrlnrgi?es in section 2.1. Minor content updates throughout

Documentation Conventions

Table 1-1. Document Conventions for Guides

Convention

Usage

Courier New

Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Italics

Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]

Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open

Represents menu paths:
File > Open > New Project

Bold

Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman

Displays an equation:
2+2=4

Text in gray boxes

Describes cautions or unique functionality of the product.

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A
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This chapter describes how to install and configure the CY3217-MiniProg1 kit

2.1 Installation

To install the CY3217-MiniProg1 kit, follow these steps:

1. Insert the kit CD into the CD drive of your PC. The CD is designed to auto-run and the kit installer
startup screen appears.
You can also download the latest installer from http://www.cypress.com/go/CY3217-MiniProg1l.
Three types of installers are available for download:

a. CY3217-MiniProgl_ISO: This file (ISO image) is an archive file of the optical disc provided
with the kit. You can use this to create an installer CD or extract information using WinRar or
similar tools.

b. CY3217-MiniProgl_Single Package: This executable file installs the contents of the kit CD,
which includes PSoC Programmer, PSoC Designer, and user documents.

c. CY3217-MiniProgl_Single Package (without prerequisites): This executable file installs only
the kit user documents.

2. Click Install CY3217-MiniProg1l Kit Content to start the installation, as shown in Figure 2-1.
Figure 2-1. Kit Installer Startup Screen

=2 CY3217-MiniProg1 Kit E]E@

<
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CY3217-MiniProg1 Kit

(L5 o 3
e Install CY¥3217-MiniProgl Kit Content...

@ 2011 Cypress Semiconductor Corporation. All rights reserved
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Note If auto-run does not execute, double-click the cyautorun.exe file on the root directory of the
CD, as shown in Figure 2-2. To access the root directory, click Start > My Computer > <drive:>
CY3217-MiniProg1l Kit.

Figure 2-2. Root Directory of the CD

Address |$} Fil

,J CY3217-MiriPrag1 Kit /J Documentation
| |
'-"h":"'d" autarun
P5aiC Prograrmmer = Setup Information
1KB

setup
43 %48
ICO File

Prerequisite ‘;J PSoC Designer
1

cyaukorun _ cyautorun
DAT File 5}--"- Cypress Aukorun Applet
1 KB Cypress Semiconductar

The InstallShield Wizard screen appears. On this screen, choose the folder location to install
the setup files. You can change the location of the folder using Change, as shown in Figure 2-3.

Click Next to launch the kit installer.
Figure 2-3. InstallShield Wizard

CY 3217-MiniProg1 Kit - InstallShield Wizard El

Welcome to the InstallShield Wizard for
CY3217-MiniProgl Kit

The IngtallShield Wizard will ingtall Cv3217-MiniProgl Kit
ar yaur computer. To continue, click Mext.

Select folder where zetup will inztall files.

G Install Cv321 7-MiriProg! Kit
C:A MCypress

cBack | Mewt> |[ Cancel l

In the Product Installation Overview window, select the installation type that best suits your
requirement.The drop-down menu has three options: Typical, Complete, and Custom, as
shown in Figure 2-4.,

Click Next to start the installation.

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A
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Figure 2-4. Installation Type Options

" Cylnstaller for CY3217-MiniProg1 Kit 1.0

Product Installation Dverview
Chooge the install type that best suits your needs

Chonse the type of installation
Praduct:
Cy'3217-MiniPragl Kit

Installation Type:

Typical w

Inztalls the most common features of
Cv3217-MiniProgl Kit

The following products need to be installed manually
Adobe Reader

’ Meut » ] ’ Cancel

|

Getting Started

7. When the installation begins, a list of packages is displayed on the Installation Page. A green
check mark appears adjacent to every package that is downloaded and installed, as shown in

Figure 2-5.
8. Wait until all the packages are downloaded and installed successfully.

Figure 2-5. Installation Page

" Cylnstaller, for CY3217-MiniProg1 Kit 1.0

Installation Page
Flease wait while zetup installz/configures Cv3217-MiniProgl Kit on your computer

Caching ~
w PSoCProgrammerSetup
el PSoCProgrammer3.13.0.951
ClockPrograrmmert. 3.0.981
USBEootloader. 361
BridgeControlPanel1.3.0.961
E xampleCode. 961
Devicelatabase. 961
PSoCDesignerSetup
PSoCDesigner_Core5.1.2306.0 1 www.cypress.com/go/kits
PSaoCDesigner_Content5.1.2306.0 ’
PSoCDesigner_Doch.1.2306.0 P

Al | 3 e‘m

- Fiirceu

In a design jam?

Statuz

llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll]
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9. Click Finish to complete the installation, as shown in Figure 2-6.

Figure 2-6. Installation Completion Page

* Cylnstaller for CY3217-MiniProg1 Kit 1.0

After software installation, verify that you have all hardware and drivers set up for the CY3217-
MiniProgl Kit by connecting the kit to your PC via its USB interface. Because this is the first time you
have connected the programmer to this PC, initial drivers are installed. Follow the instructions to
complete the installation process.

Verify your installation and setup by opening PSoC Programmer with the MiniProgl connected to
USB.

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A
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PSoC Designer is the integrated design environment (IDE) that enables you to customize your PSoC
application. The latest version of PSoC Designer has many new features, bug fixes, and support for
PSoC devices. Download and install the latest version from http://www.cypress.com/go/psocde-
signer.

To open PSoC Designer:

1.

Click Start > All Programs > Cypress > PSoC Designer <version> > PSoC Designher <ver-

sion>.

To create a new project in PSoC Designer, click File > New Project.
To open an existing project in PSoC Designer, click File > Open Project/Workspace....

Figure 2-7. PSoC Designer Interconnect View

Global Resources

Menus

 achy Example_ADC_UART_| TD - PSoC Designer 5.°

Toolbar

Workspace Explorer

Datasheet

Resource Meter

Ek ogram  Tools  Window  Help
f i* B 0%, im »lama @,
Gobal Resources = . = & X | 501 page  asm_ewamp..t_led [Chip] | 7 4 b x | Worksmace £xplo worce Moter = 3 K
Powar 5 5.0/ 4MHz =~ T =" mTe = Watkzpace WEM_Example_al Digtal Blocks Tatat 16 Used::
CPU_Ch Syelik /B o 1 = [ ASM_Example ADC_U| I'll'l'lil
30K Se Inkemal [T = [ ASH_Example_A0C_| [—
PLL_Mc Disaile 2 (& Loadable Conigu{ [ Analog Blecks Tatat 12 Used
Skeap_T 512_Hz = s _ewarmple_ 12-Bit Incremental ]
WC1=5, 8 = _ERLEE ADC Data Sheet
WE2=W1 i O Leot vl FaM Total 204% Used 25
VL3 Sou SpeCk/1 3 W i Resources PsoC® Block: |1
e B USRT ;
Power Setting [ Yee / T A5M_Example 40T RO Tobat 22768 Used_ﬂl]'n
Selects the rominal operation 4 [ ASM_E a0c Y - '—
wclinge and System Clack . {3 ASM_Example ADC_| ] e :
[5Ck] sowrce, from which ., - 1 cT Dezimator Totat 1 Used 0
= CYBCINTT/Za2200, 2 0
Persmeters- ADCL.. = B X CYECI]33, 120 Conirolles Totalk 1 Used: 0
Harme ADCINC1Z_1 CYECLEDOHDEME,
M H — CYBL2RxaS,
CYBE2EmE3,
CoskPin Mo = £ ¥| cveczaes:
THR Cl WC1 ___ | Lser Modulss X orwusssss: 0 ]
Ingat ACEOT ; - . i | [ ] User Madues
1 - > 4 ADC
CHT Cloc VC1 : T oy i j ot See AMZZII_ADC Selecticn
L : L L B £3 Andog Comm Gutiche for ather canvemers
Mame il 1 @ Ceurners
Irchcabes the name wsed b — - p— 5 - DACs
ey thiz User Modubzin . & 0@ Digid Comm Featur:es and
& O Fibers Overview
Pinout - asm_ecam... = 0 X F 1 Gareic
B PO[]  Pol_ 00, StdCF & L Legacy » 12-bit resolution, 2's
@ PO VA, Analkginpi i L Mizz Dighsl complemant
B P02 Pait 02, 5101 e £ MU + Sample rata from 7 &
@ PO[3|  Pait_0_3, StC1 ® (3 Froncok 5ps 10 480 sps
B PO4] | Port 04, SedCF ® L3 Pkl « Input range AGHD +/-
B POS]  Pol_0_5, StdCF [ Random Seq .
B POE]  Poil_0_8, SidCt L RF o .
@ PYT|  Pail 0_7, SICI i Temperstuie + Provides normal made
[ PIO]  Poit_1_0. Stk B [ Timers rejection of figh v
Bl P[] g Poi_1_1. 510k | | ] 2
Ready

User Module Catalog

Pinout Info Chip Editor View

Note For more information on PSoC Designer, see the PSoC Designer IDE Guide located at:
<Install_Directory>:\Cypress\PSoC Designer\<version>\Documentation

See Additional Learning Resources on page 5 for links to PSoC Designer training. The PSoC
Designer quick start guide is available at: http://www.cypress.com/?rID=47954.

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A 11
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2.3 PSoC Programmer

PSoC Programmer provides programming support for all PSoC devices. Download and install the
latest version of PSoC Programmer from http://www.cypress.com/go/psocprogrammer.

1. To open PSoC Programmer, click Start > All Programs > Cypress > PSoC Programmer <ver-
sion> > PSoC Programmer <version>.

2. Select the MiniProgl from Port Selection, as shown in Figure 2-8.

Figure 2-8. PSoC Programmer Window

. PSoC Programmer.

7 = Program
Filz  Viex Options _ Heln Toadle P
oggle Fower
sl | f— @ File Load ad
J Port Selection Alp | Programmer | Utiliies | JTAG |
0 MINIPiog] /07ADS1CE3E15| | - Pragramming Parameters
Eile Path FaFirmware3h_Example_DAC_ADCASM_Example_DAC_ADC hex
Part Connectivity
Prograrnrnet: rIMIProg1/07 4051 CEZE15 ‘
‘ Progtatnming hode: Reset Powver Cycle Power Detect
Werification: On Off Connector: Sp 10p ‘
I LutoDetection;
Device Family s On Ot Clock Speed
r Pragrammer Characteristics Status
Protocol  JTaG | GwWD * IS8R ) |pc | ExecutionTime: 47.0ssconds
Has votage: @) 50y a3y O 25y O fay || Cherbabe - on
Voltage: [
Actions Results Lo
Programming Starting
Erase Succeedesd
Device set to
CYBCE28466-24PXI at 32768 FLASH bytes
12:18:13 PN
Device Family set to
29x66 at 12:18:13 FI
Automatically Detected Device: CYSC29466-24PZI
Program Reguested at
1z:18:12 PN
Program Finished at
12:17:59 FM
Programming Succesded v
ForHelp, pressft. ~~ [JAANIRREREEEE

3. Click the File Load button to load the hex file.
4. Click Program to program the hex file.
5. Close PSoC Programmer.

Note For more information on PSoC Programmer, see the user guide located at:
<Install_Directory>:\Cypress\Programmer\<version>\Documents.

12 CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A
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3.1 Introduction

The CY3217-MiniProgl Kit can be used as an ISSP to program PSoC 1 devices. The MiniProgl is
an interface that programs chips using PSoC Programmer. It enables the PC host software to com-
municate through high-speed USB to the target device to be programmed, as shown in Figure 3-1.

Figure 3-1. PC to Target Board Interface

PC

USB Cable —»

MiniProg1l

5-pin Direct
Connection

Target Board

Note In-system serial programming (ISSP) is a Cypress legacy interface used to program the
PSoC 1 family of microcontrollers. For more information about the ISSP interface, see the PSoC 1

Technical Reference Manual.

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A 13
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You can start PSoC Programmer from the Windows desktop or through PSoC Designer. Set up all

hardware, including the device to program, before you start PSoC Programmer.

1. To open PSoC Programmer from the desktop, click Start > All Programs > Cypress > PSoC
Programmer <version> > PSoC Programmer <version>.

Figure 3-2. PSoC Programmer View

% PSoC Programmer

File  Vie Optians Help

Program

&

File Load

Toggle Power

| Port Selection

| Programmer | Uilties | JTAG |

@ MINIProg1 /07ADS1CE361S|

Fort Connectivity

Programming Parameters
File Path:

Erogrammer.

FiFirmuwareldShd_Exarmple_DAC ADCIASM_Example_DAC_ADC. hex

MINIPrag /074051 CEIES

Programming Mode Reset Power Cycle Power Detect
Werification: On Off Connector: Sp 10p
|| AutoDetect <
Device Family Mg slenen On off Clock Bpeed
Prograrmmer Characteristics Status
= || Protocol:  yag swD * 1SSE O 2c Execution Time: 470 seconds
Device Maltags: Biy 39y JEy 1Ay Power Status: (=11}
. Vaoltage (81 i
Actions Results e

Device set to
CYBCZ94AA-Z4PXI at
12:18:13 FM

Device Family set to
29x66 ar 12:15:13 FH

Program Recquested at
12:18:12 FM
Program Finished at
12:17:59 PM

Programming Starting
Erase Succeeded

32768 FLASH bytes

Auytomatically Detected Device:

Prooramming Succeedsd

CYBCEZ8466-24PXI

-

For Help, press F1

TRERNRNNRNRARE pusy [ Paweredi] [ iCennectsd 0

2. To open the program from within PSoC Designer, load the target project that contains the hex file
and the device to program.

3. Select Program > Program Part to launch the embedded programmer.

Select Programmer View Options

PSoC Programmer can be run as a standalone application or can be called as a COM object from
other programs. The programmer interface is flexible and can be presented from within other pro-
grams. You can choose an interface based on the requirements of your program.

To choose a new view of the programmer, select View menu for options.

Figure 3-3. Programmer View Options

File | Wiew | Options
l_m Taool Bar
Skatus Bar

m Classic

oM Modetn

Simple

Help
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m Classic: This is similar to the Programmer 2.3x. Some updated features of Programmer 3.x are
not available in this view. This mode retains the look and feel of PSoC Programmer 2.x. Cypress
recommends using the Modern View.
Modern: This is the default and most feature-rich view of PSoC Programmer.
Simple: This is the basic view; load a hex file and program.
3.4 Select Programmer Options
Click Options > Programmer Options to view the following window.
Figure 3-4. Programmer Options
z» Programmer Options
Auto-Update of Firmware Parhal Program
PSaC Programmer will automatically update Accelerated programming option will read
the: Firmware of the connected Programmer the target PSoC3/4/5 device and wite
only the changes to the flazh zpace
() Enable  (3) Dizable
Enabl Disabi
Shiow Popup if Firmware iz out-of-date Sl Ok
Auto-Reset of Chip Clear EEFROM
PSalC Programmer will initiate a toggle of Clear EEPROM data after programming
the =RES line after Reset Programming [uze only for PSoC3/5 devices)
(& Enatle ) Disable (O Enable (3 Disable
[ QK ] l Cancel
3.4.1 Automatic Firmware Update

The Programmer Options dialog provides the option to enable automatic firmware upgrades for
programmer hardware. These automatic updates apply to all programmers that support in-field
upgrade of firmware. The option can be changed at any time, even when programmer is not con-
nected. You can enable or disable the automatic updates of firmware.

3.4.2 Automatic Chip Reset

The Programmer Options dialog also provides an option to enable or disable toggling of the XRES
line after the programmer operation (such as Program, Checksum, and Read) is complete. This
option is applicable only if the chip is acquired in Reset mode.

35 Select Port

To select a port, click the port you are using to connect to the programming device, as shown in
Figure 3-2.

When changing ports, PSoC Programmer attempts to connect to the selected port and displays the
port status in the lower right corner of the window. If you are connected to a device on another port,
PSoC Programmer disconnects from the original device before connecting to the new device.

USB ports are added to the port list automatically when a programming device is connected and
removed from the list when disconnected.

Setting a base and part device allows the programming operations to perform actions based on the
characteristics of the PSoC device. For example, CY8C24794 parts require Power Cycle Program-
ming Mode because the reset pin is not available for Reset Programming Mode. Flash sizes are

CY3217-MiniProgl Kit Guide, Spec. # 001-66541 Rev. *A 15
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determined by selecting a PSoC device. Flash size is important when the verify operation is per-
formed. Changing the device enables or disables Acquire Mode options and displays flash size infor-
mation in the status window.

To select a device:

By default, PSoC Programmer is set to autodetect the device. Programmer queries the device and

sets the device based on the result. Click the Program button when you are ready to program and

the proper device is selected.

To select a device with autodetection off:

1. Click the Device Family drop-down list and select the target device family.

2. Click the Device drop-down box and select the target device associated with the target device
family.

Figure 3-5. PSoC Programmer Device Selection

Luutol
Device Family —
21534 - Frogi
Proto
Device Valta

CvBC2T434-24LF= | »

Cr8C21334-12PWHE o~
CvBC2T334-24P00,
Cr8C21 334 - 24P

137 PHM
HCv'BC21534-12PWVi=E 17 PM
CvBC21 5234 - 24P,
CvEC21534- 24P pected

HOWBC21634-24LFxl ™

Programming Characteristics

Depending on the programmer capabilities, you can select various protocols. Some programmers
are single protocols, but others allow you to select different protocols. The Device Family and
Device drop-down menus adjust according to the protocol selected and the device to be pro-
grammed. It supports the ISSP protocol.

Voltage supplied by MiniProgl to target board is 5 V and total current supplied by MiniProgl to the
target board being programmed is 302 mA.

Note Total current supplied to MiniProgl from the USB port is 500 mA, current consumption is
198 mA. Hence, total current supplied to the target board is 302 mA (difference between total current
supplied and current consumption).

Select Programming Mode

Programming mode determines how PSoC Programmer acquires the device for programming.

There are two modes:

1. Reset — Used for ISSP header programming on a self-powered target application board. In this
mode, the target board supplies the power and the programmer uses the reset pin to acquire.

2. Power Cycle — Used when the programmer requires power. The programmer cycles power to
acquire. Select the Power Device checkbox if your target board is not self powered.

Note You cannot use the Reset Programming Mode on devices that do not have an XRES pin.
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3.7 Select Hex File

Load a hex file into PSoC Programmer before programming a device. PSoC Programmer only pro-
grams devices using hexadecimal files (*.hex). If your project is not compiled into hexadecimal for-
mat, use PSoC Designer to prepare your project for programming before continuing.

To select a file for programming:

1. Click File Load or press [F4].

2. Inthe Open dialog, browse to the folder containing the file, then select a file.

3. Click Open.

3.8 Program a Device

To program a device:

1. Load the hex file.

2. Click Connect.

3. Click Program or press [F5].

The program operation erases, programs, verifies, protects, and performs a checksum. The verify is
performed before the protect action, so all blocks are verified.

3.8.1 Turn Verification Off

When debugging your program, you may make changes, rebuild, and reprogram a device frequently.
To save time during this process, turn the Verification stage off. This saves approximately 30 per-
cent of the total programming time. Do not turn Verification off for production programming.

3.8.2 Verify Programming

To verify device programming, click File > Verify or press [F8]. This is different from the verification
done automatically during programming, as protected blocks are not verified. If the device is read
protected, the verify operation fails. On completion, PSoC Programmer specifies the number of pro-
tected blocks.

The results of the verify procedure fills the text window, flowing up from the initial operation com-
mand. To save or copy the results, right-click the text window and select Copy or Save As from the
drop-down menu.

3.9 Upgrade Firmware

Firmware for programmers must be updated to support new and updated PSoC devices and to
ensure that the latest bug fixes are applied. When PSoC Programmer starts, or when a different port
is selected, programmer checks the connected programming device firmware. To upgrade firmware,
go to Utilities > Upgrade Firmware, as shown in Figure 3-6.
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Figure 3-6. Upgrade Firmware

Programmer IUtiIitiesI JTAG

[ Uparade Firrmware ] Click to upgrade connected device's firmware
[ Check For Update ] Click to check weww cypress com for updates ba PSoC Programmer
[ Update Reminder ] Click to zet or change update reminder preferences

Eraze Block Click to erase uzer zpecific flazh block

Abort a Process

Programming and other long processes can be aborted. The Abort button is enabled only when
PSoC Programmer is in a busy state. The busy state indicates that the programmer is executing an
action such as Program, Verify, Checksum, Read, and Upgrade Firmware. You can click the Abort
button at any time during a busy state. This aborts execution of the current operation.

The abort function is useful when you click Program with the PSoC device not connected to the pro-
grammer or when attempting to acquire a device using the Reset mode, when the device is not pow-
ered. The Acquire operation takes about 20 seconds to time out. Use the Abort button to avoid
waiting for timeout.

If you abort programming of the chip's flash contents, the chip can be in an unknown state. In this
case, reprogram; otherwise, the device fails in execution.

Read

Click Read or press [F7] to read the contents of a device. Device contents are displayed in hexadec-
imal, as shown in Figure 3-7.
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3.12

3.13

3.13.1

3.13.2

Figure 3-7. PSoC Programmer

. PSoC Programmer

File  view Options Help

~

@0
|F’ortSeIactian 4p  Programmer | Utilities | JTAG
MINIProgT /852671021000

Programming Parameters
Eile Path DACY32351Kit COWFirmwarelproximity_ref_des_21434_cssd hex

Programmer. bIMIProg1/852671021 000
Froararnming Mode: (O Reset (& Paower Cycle
® on O off

® on O off
Programmer Characteristics Status

Prowcol.  Jjae  @wh @ IssP jpc  Execution Time: 9.2 seconds

T valteoe. ® 5oy 33y 25y 1gy | Cowerdisue  OFF
CYC2143424FX v Valtage: NA

Ponrer Detect
Verification;
AutoDetection

Connectar: Sp 10p
Clock Bpeed:

Device Family
| 2134 ~|

Device

Actions Results

Read Finished at

10:56:20 AM
0000: xx XX XX XX XX XX XX XX XX XX HF XX XX XX XX XX
0010: X XX XX XX HX XX XX HN XX XX HX XX XX XX XX XX
0020: x=x XX XX XX XX XX XX XX XX XX HM XX XX XX XX XX
0030: XX XX XX XX HX XX XX HN XX XX HX XX XX XX XX XX
0040: xx XX XX XX XX X¥ XX XX XX XX RN XX XX XX XX XX
0050: XX XX XX XX XX XX XX MM XX XX HX XX XX XX XX XX
0060: xx XX XX XX XX XX XN XX XX XX HH XX XX XX XX XX
0070: XX XX XX XX HX XX XX HN XX XX HX XX XX XX XX XX
0080: Ve 30 30 30 7e 30 30 30 7= 30 30 30 7d 11 3e 7=
0090: 7d 07 be 7e 7e 30 30 30 7e 30 30 30 7e 30 30 30
00aD: 7e 30 30 30 7e 30 30 30 7= 30 30 30 7e 30 30 30
00pD: 7e 30 30 30 7Ye 30 30 30 7e 30 30 30 7e 30 30 30
00cD: Fe 30 30 30 7d 08 30 7e 62 d0 00 50 03 57 6o 0B
00d0: 28 53 e2 18 75 09 00 25 4b 51 e2 50 04 75 09 0O
O0eD: 62 23 00 0B 268 60 d5 74 a0 4b 18 75 05 00 08 2B
O0f0: 53 ez 18 75 09 00 08 25 a0 1o 53 el1 18 75 09 0O

For Help, press F1

Flash security data is displayed along with the read values in the PSoC Programmer Results win-
dow. Unprotected blocks are displayed as ‘U’. Protected block are displayed as ‘xx’. See the PSoC
Designer IDE Guide for information about protecting flash.

Checksum

Click Checksum or press [F6] to perform a checksum operation on a device. If a hex file is loaded,
device values are compared to the loaded file. Read and Checksum operations may be completed
without a loaded hex file.

Erase Flash

The flash on the device attached to the programmer can be erased completely, or block by block.

Erase a Block

To erase a block, the flash security for the block must be set to U, unprotected. See the PSoC
Designer IDE Guide for information about protecting flash.

Erase Flash Contents

To erase all flash content, select File > Erase All Flash or press [F9]. The Erase All function per-
forms a series of steps that destroys the data in the flash banks and resets the protection block in
each flash bank to unprotected.
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Patch Image

To use this option, select File > Patch Image or press [F12]. You can load a hex file and connect the
MiniProgl to the target device. PSoC Programmer reads the flash content on the target device and
compares it with the selected hex file. Then, PSoC Programmer replaces the flash blocks. This fea-
ture is useful to replace calibration data or a manufacturing number.

MiniProg1l
Figure 3-8. MiniProgl Details

Red Target Powered

Status LED

USB Mini B
Connector

Serial Data ~

Serial Clock

Connect MiniProg1l

The PSoC 1 device can be programmed using a MiniProgl by connecting it to the ISSP header on
the board, as shown in Figure 3-9.

Figure 3-9. Connect MiniProgl

Red LED

ISSP Header

Note Ensure that the first pin (Vdd) of MiniProgl is connected to the first pin (Vdd) of the ISSP pro-
gramming header on the target board.
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3.15.2  Program with MiniProgl

Follow these steps to program using MiniProg1.:

Connect the USB cable to the PC and MiniProgl.

Plug in the MiniProg1 to the ISSP header on the target board.

When USB is connected to the MiniProgl, the green LED glows in the MiniProg1.

Open PSoC Programmer (see Start PSoC Programmer on page 14 for details).

Click the File Load button and browse to the hex file location. Select the hex file and click Open.

Click Connect or double-click on the respective MiniProg under Port Selection to connect to the

MiniProg.

7. Click Program or press [F5] to initiate programming (see Program a Device on page 17 for
details).

8. The green LED on the MiniProg1l blinks to indicate the progress of programming.

9. After successful programming, the red LED on the MiniProg1l is powered off.

10.Select the Toggle Power button in PSoC Programmer to power the board via MiniProgl and ver-
ify output.

Note When MiniProgl cable is unplugged from PC during programming, programming fails, as
shown in Figure 3-10.

o0k wbdhpRE

Figure 3-10. PSoC Programmer

L. PSoC Programmer

File. Wiew Options Help
s OB 0D
J Part Selection 4lb | Programmer JL_J}‘!_'E'F_S_ | JTAG |
@) MINIFrog1 /932158162410 || - Pragramming Parameters
File Path: FiFirrmwarel20x66_CSAWCYI280_20x66_Project\Cv3280_20x66_Project] . hex
Programmer. MINIProg1/88215B162410
Broaramming Mode: &) Reset () Power Cycle Powver Detect
Verification: @ on O off Connector: S ° 10p
= AutoDetection; )
Device Famly futoDetection: ® on O off Clock Speed
I-Z-SXEB B \,' Programimer Characteristics Status
' — | Protcok  grag  swD @ I188P jpq  ExecufionTime: 334 seconds
D 5 Power Status:
|| Yoltane: @ gy 33y 2BV 18V | oo Lk
| CYBC204E6-24P% 1w | Aoltage L) i
Actions Results o
Successfully Connected
o
MINIProgi/os215Biezaip oL Version 1.79
at 6:28:10 FH
Opening Port at 6:26:08
FM
11:;“ Closed at 6:26:08 ) onnected from WINIProgl/S82158162A1D
Program Finished at
6:25:47 PN
FAILED! Can not Acguire Device! Please wverify the device connection to the Programmer
Program Recuested at
6:25:14 FH o
For Help, press F1 [ ([CRAIET) [NatPowered |
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A.l Programming Header

This section discusses the design consideration and component selection for the programming
header on the target board.

The 5-pin connector on MiniProgl is configured as a single row with a 100-mil pitch. It is designed to
mate with a Molex model 22-23-2051 (straight) or 22-05-3051 (right angle) male header, with a key
tab. The signal assignment is shown in Figure A-1.

Figure A-1. Signal Assignment

==
.— SDAT ——-—.
® <« —©
@ xres ——@)
.77 GND 74.
.— VDD ——.
]
MiniProgl (End View) Mating Header on Target Board

Figure A-2. Proposed Schematic for Mating Header (on target board)

ISSP Vdd
J1
L |
2
g 3 XRES
>[4 SCLK
2|5 SDATA
HDR 1x5
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See the respective PSoC 1 data sheet for pin SCLK and SDATA pin assignments.
Figure A-3. Proposed Header (on target board)

This is a five position, 2.54 mm (.100") pitch header from Molex Inc (Part No. 22-23-2051).

For details on the header, visit http://www.molex.com/molex/products/datasheet.jsp?part=active/
0022232051 _PCB_HEADERS.xml&channel=Products.
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